npm/yarnで使用しているパッケージのバージョンを調べる

2020.09.24
npm/yarnで使用しているパッケージのバージョンを調べる

npm/yarn を使ったプロジェクトに導入しているパッケージのバージョンを調べる方法です。

使用中パッケージのバージョンを知る

$ npm ls --depth=0 | grep <パッケージ名> で調べる事が出来ます。
yarnの場合は $ yarn list --depth=0 | grep <パッケージ名>

# 今回知りたい nuxt は2.14.3を使用していることが分かる
$ npm ls --depth=0 | grep nuxt

2:├── @nuxt/content@1.8.1
3:├── @nuxt/types@2.14.4
4:├── @nuxt/typescript-build@2.0.2
5:├── @nuxt/typescript-runtime@1.0.0
14:├── nuxt@2.14.3

導入パッケージの情報を知る(余談)

プロジェクトに導入しているバージョンが分かったところで、
「じゃあこのパッケージの公開されている最新版はいくつなんぞ?」というのを調べられるのが $ npm info <パッケージ名>

$ npm info nuxt

nuxt@2.14.5 | MIT | deps: 10 | versions: 245
A minimalistic framework for server-rendered Vue.js applications (inspired by Next.js)
https://github.com/nuxt/nuxt.js#readme

keywords: nuxt, nuxt.js, nuxtjs, ssr, vue, vue isomorphic, vue server side, vue ssr, vue universal, vue versatile, vue.js, vuejs

bin: nuxt

dist
.tarball: https://registry.npmjs.org/nuxt/-/nuxt-2.14.5.tgz
・・・


yarnの場合は $ yarn info <パッケージ名>

# jsonで出力される
$ yarn info nuxt

yarn info v1.22.4
{
  name: 'nuxt',
  description: 'A minimalistic framework for server-rendered Vue.js applications (inspired by Next.js)',
  'dist-tags': {
    latest: '2.14.5',
    '1x': '1.4.5'
  },
  versions: [
    '0.0.1',
    '0.1.0',
    '0.1.1',
    '0.1.2',
    '0.1.3',
    '0.1.4',
    '0.1.5',
・・・

おすすめ